aboutsummaryrefslogtreecommitdiff
path: root/tools/strelka-call.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2019-01-15 14:31:15 +1100
committerJustin Bedo <cu@cua0.org>2019-01-15 14:31:15 +1100
commit2bf74101a862d0417ccda2bafe55e0d2616d1e1a (patch)
tree159d71089e2057f711bf756e18fdea9a494b3825 /tools/strelka-call.nix
parentddd1c7549995600ab32c5b7a9112334681d3ea8a (diff)
strelka: add germline calling
Diffstat (limited to 'tools/strelka-call.nix')
-rw-r--r--tools/strelka-call.nix8
1 files changed, 3 insertions, 5 deletions
diff --git a/tools/strelka-call.nix b/tools/strelka-call.nix
index 8505302..cbdcfb4 100644
--- a/tools/strelka-call.nix
+++ b/tools/strelka-call.nix
@@ -4,7 +4,7 @@
, flags ? null
}:
-{normal, tumour}:
+inputs:
with bionix;
with lib;
@@ -13,7 +13,6 @@ with types;
let
filename = path: last (splitString "/" path);
getref = f: matchFiletype "strelka-call" { bam = x: x.ref; } f;
- inputs = [ normal tumour ];
refs = map getref inputs;
ref = head refs;
@@ -30,9 +29,8 @@ stage {
${concatMapStringsSep "\n" (p: "ln -s ${p} ${filename p}.bam") inputs}
${concatMapStringsSep "\n" (p: "ln -s ${bionix.samtools.index bamIndexAttrs p} ${filename p}.bai") inputs}
- configureStrelkaSomaticWorkflow.py \
- --normalBam ${filename normal}.bam \
- --tumourBam ${filename tumour}.bam \
+ configureStrelkaGermlineWorkflow.py \
+ ${concatMapStringsSep " " (i: "--bam ${filename i}.bam") inputs} \
--ref ref.fa \
--runDir $TMPDIR