aboutsummaryrefslogtreecommitdiff
path: root/tools/strelka-call.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2019-05-09 14:23:53 +1000
committerJustin Bedo <cu@cua0.org>2019-05-09 14:23:53 +1000
commit6137d292d8d721490bf6ded2695cdc71755aff59 (patch)
tree7e26b12750b73120509bb886a82bea319ae688ac /tools/strelka-call.nix
parent795c1ce6b03bfa1cefb628026e08371f39b86296 (diff)
strelka: rewrite to use multiple outputs
Diffstat (limited to 'tools/strelka-call.nix')
-rw-r--r--tools/strelka-call.nix10
1 files changed, 8 insertions, 2 deletions
diff --git a/tools/strelka-call.nix b/tools/strelka-call.nix
index bc1e202..dc07291 100644
--- a/tools/strelka-call.nix
+++ b/tools/strelka-call.nix
@@ -20,9 +20,11 @@ in
assert (length (unique refs) == 1);
-stage {
+let
+out = stage {
name = "strelka-call";
buildInputs = with pkgs; [ strelka ];
+ outputs = [ "out" "variants" ];
buildCommand = ''
ln -s ${ref} ref.fa
ln -s ${bionix.samtools.faidx indexAttrs ref} ref.fa.fai
@@ -48,8 +50,12 @@ stage {
sed -i '/^##fileDate/d' $g
sed -i '/^##startTime/d' $g
done
+ mv variants.vcf $variants
+ ln -s $variants variants.vcf
mkdir $out
cp -r * $out
'';
passthru.multicore = true;
-}
+};
+ft = {filetype = types.filetype.vcf {ref = ref;};};
+in out // { variants = out.variants // ft; }