aboutsummaryrefslogtreecommitdiff
path: root/tools/strelka-callSomatic.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2019-01-17 09:34:34 +1100
committerJustin Bedo <cu@cua0.org>2019-01-17 09:34:34 +1100
commit39de5e9a3e9f6345442146cca342565b29640a42 (patch)
tree9ffabda0db9f0d0dd418908994198042bedb4bac /tools/strelka-callSomatic.nix
parentd9223958d2d83a936719694db63c4777a8dde274 (diff)
strelka: refactor vcf extraction
Diffstat (limited to 'tools/strelka-callSomatic.nix')
-rw-r--r--tools/strelka-callSomatic.nix28
1 files changed, 7 insertions, 21 deletions
diff --git a/tools/strelka-callSomatic.nix b/tools/strelka-callSomatic.nix
index 888e589..6d379f9 100644
--- a/tools/strelka-callSomatic.nix
+++ b/tools/strelka-callSomatic.nix
@@ -17,14 +17,12 @@ let
refs = map getref inputs;
ref = head refs;
- drv = bionix.strelka.callSomatic {inherit indexAttrs bamIndexAttrs flags;} {inherit normal tumour;};
-
in
assert (length (unique refs) == 1);
stage {
- name = "strelka-callSomatic";
+ name = "strelka";
buildInputs = with pkgs; [ strelka gzip ];
buildCommand = ''
ln -s ${ref} ref.fa
@@ -33,27 +31,15 @@ stage {
${concatMapStringsSep "\n" (p: "ln -s ${bionix.samtools.index bamIndexAttrs p} ${filename p}.bai") inputs}
configureStrelkaSomaticWorkflow.py \
- --normalBam ${filename normal}.bam \
- --tumourBam ${filename tumour}.bam \
- --ref ref.fa \
- --runDir $TMPDIR
+ --normalBam ${filename normal}.bam \
+ --tumourBam ${filename tumour}.bam \
+ --ref ref.fa \
+ --runDir $TMPDIR
./runWorkflow.py \
- -m local \
- -j $NIX_BUILD_CORES
+ -m local \
+ -j $NIX_BUILD_CORES
cp -r results $out
'';
- passthru = {
- indels = stage {
- name = "strelka-callVariants-indels";
- buildCommand = "ln -s ${drv}/variants/somatic.indels.vcf.gz $out";
- passthru.filetype = filetype.gz (filetype.vcf {ref = ref;});
- };
- snvs = stage {
- name = "strelka-callVariants-snvs";
- buildCommand = "ln -s ${drv}/variants/somatic.snvs.vcf.gz $out";
- passthru.filetype = filetype.gz (filetype.vcf {ref = ref;});
- };
- };
}