aboutsummaryrefslogtreecommitdiff
path: root/tools/strelka-callSomatic.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2019-05-09 14:23:53 +1000
committerJustin Bedo <cu@cua0.org>2019-05-09 14:23:53 +1000
commit6137d292d8d721490bf6ded2695cdc71755aff59 (patch)
tree7e26b12750b73120509bb886a82bea319ae688ac /tools/strelka-callSomatic.nix
parent795c1ce6b03bfa1cefb628026e08371f39b86296 (diff)
strelka: rewrite to use multiple outputs
Diffstat (limited to 'tools/strelka-callSomatic.nix')
-rw-r--r--tools/strelka-callSomatic.nix13
1 files changed, 11 insertions, 2 deletions
diff --git a/tools/strelka-callSomatic.nix b/tools/strelka-callSomatic.nix
index cf4b414..cce6243 100644
--- a/tools/strelka-callSomatic.nix
+++ b/tools/strelka-callSomatic.nix
@@ -21,9 +21,12 @@ in
assert (length (unique refs) == 1);
-stage {
+let
+
+out = stage {
name = "strelka-callSomatic";
buildInputs = with pkgs; [ strelka ];
+ outputs = [ "out" "indels" "snvs" ];
buildCommand = ''
ln -s ${ref} ref.fa
ln -s ${bionix.samtools.faidx indexAttrs ref} ref.fa.fai
@@ -50,8 +53,14 @@ stage {
sed -i '/^##fileDate/d' $g
sed -i '/^##startTime/d' $g
done
+ mv somatic.indels.vcf $indels
+ ln -s $indels somatic.indels.vcf
+ mv somatic.snvs.vcf $snvs
+ ln -s $snvs somatic.snvs.vcf
mkdir $out
cp -r * $out
'';
passthru.multicore = true;
-}
+};
+ft = {filetype = types.filetype.vcf {ref = ref;};};
+in out // { indels = out.indels // ft; snvs = out.snvs // ft;}