aboutsummaryrefslogtreecommitdiff
path: root/tools/strelka.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2019-01-17 09:34:34 +1100
committerJustin Bedo <cu@cua0.org>2019-01-17 09:34:34 +1100
commit39de5e9a3e9f6345442146cca342565b29640a42 (patch)
tree9ffabda0db9f0d0dd418908994198042bedb4bac /tools/strelka.nix
parentd9223958d2d83a936719694db63c4777a8dde274 (diff)
strelka: refactor vcf extraction
Diffstat (limited to 'tools/strelka.nix')
-rw-r--r--tools/strelka.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/tools/strelka.nix b/tools/strelka.nix
index 04facb9..9a8f1aa 100644
--- a/tools/strelka.nix
+++ b/tools/strelka.nix
@@ -1,8 +1,26 @@
{ bionix }:
with bionix;
+with types;
{
callSomatic = callBionixE ./strelka-callSomatic.nix;
call = callBionixE ./strelka-call.nix;
+ variants = drv: stage {
+ name = "strelka-call-variants";
+ buildCommand = ''
+ ln -s ${drv}/variants/variants.vcf.gz $out
+ '';
+ passthru.filetype = filetype.gz (filetype.vcf {ref=ref;});
+ };
+ indels = drv: stage {
+ name = "strelka-callVariants-indels";
+ buildCommand = "ln -s ${drv}/variants/somatic.indels.vcf.gz $out";
+ passthru.filetype = filetype.gz (filetype.vcf {ref = ref;});
+ };
+ snvs = drv: stage {
+ name = "strelka-callVariants-snvs";
+ buildCommand = "ln -s ${drv}/variants/somatic.snvs.vcf.gz $out";
+ passthru.filetype = filetype.gz (filetype.vcf {ref = ref;});
+ };
}