aboutsummaryrefslogtreecommitdiff
path: root/tools/strelka.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2019-05-09 14:23:53 +1000
committerJustin Bedo <cu@cua0.org>2019-05-09 14:23:53 +1000
commit6137d292d8d721490bf6ded2695cdc71755aff59 (patch)
tree7e26b12750b73120509bb886a82bea319ae688ac /tools/strelka.nix
parent795c1ce6b03bfa1cefb628026e08371f39b86296 (diff)
strelka: rewrite to use multiple outputs
Diffstat (limited to 'tools/strelka.nix')
-rw-r--r--tools/strelka.nix32
1 files changed, 0 insertions, 32 deletions
diff --git a/tools/strelka.nix b/tools/strelka.nix
index d3068b5..16f4a2b 100644
--- a/tools/strelka.nix
+++ b/tools/strelka.nix
@@ -12,36 +12,4 @@ with types;
Type: call :: {...} -> [input] -> results
*/
call = callBionixE ./strelka-call.nix;
- /* Extract VCF file from results
- Type: variants :: results -> vcf
- */
- variants =
- # result of call
- drv: stage {
- name = "strelka-call-variants";
- buildCommand = ''
- ln -s ${drv}/variants/variants.vcf $out
- '';
- passthru.filetype = filetype.vcf {ref=ref;};
- };
- /* Extract indels from somatic results
- Type: indels :: somatic results -> vcf
- */
- indels =
- # result of callSomatic
- drv: stage {
- name = "strelka-callVariants-indels";
- buildCommand = "ln -s ${drv}/variants/somatic.indels.vcf $out";
- passthru.filetype = filetype.vcf {ref = ref;};
- };
- /* Extract SNVs from somatic results
- Type: snvs :: somatic results -> vcf
- */
- snvs =
- # result of callSomatic
- drv: stage {
- name = "strelka-callVariants-snvs";
- buildCommand = "ln -s ${drv}/variants/somatic.snvs.vcf $out";
- passthru.filetype = filetype.vcf {ref = ref;};
- };
}