aboutsummaryrefslogtreecommitdiff
path: root/tools/strelka.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2019-04-07 21:10:25 +1000
committerJustin Bedo <cu@cua0.org>2019-04-07 21:10:25 +1000
commite5a8870358713f4e44e135da913c50230d83d4f1 (patch)
tree9678b00f5b683f0d3df31c11ff2c96c0a597cb0f /tools/strelka.nix
parente97bc0b22b9f49d95d6b449b2b20e7222b42622d (diff)
modify outputs to ensure determinism
Diffstat (limited to 'tools/strelka.nix')
-rw-r--r--tools/strelka.nix12
1 files changed, 6 insertions, 6 deletions
diff --git a/tools/strelka.nix b/tools/strelka.nix
index 1cf8961..d3068b5 100644
--- a/tools/strelka.nix
+++ b/tools/strelka.nix
@@ -20,9 +20,9 @@ with types;
drv: stage {
name = "strelka-call-variants";
buildCommand = ''
- ln -s ${drv}/variants/variants.vcf.gz $out
+ ln -s ${drv}/variants/variants.vcf $out
'';
- passthru.filetype = filetype.gz (filetype.vcf {ref=ref;});
+ passthru.filetype = filetype.vcf {ref=ref;};
};
/* Extract indels from somatic results
Type: indels :: somatic results -> vcf
@@ -31,8 +31,8 @@ with types;
# result of callSomatic
drv: stage {
name = "strelka-callVariants-indels";
- buildCommand = "ln -s ${drv}/variants/somatic.indels.vcf.gz $out";
- passthru.filetype = filetype.gz (filetype.vcf {ref = ref;});
+ buildCommand = "ln -s ${drv}/variants/somatic.indels.vcf $out";
+ passthru.filetype = filetype.vcf {ref = ref;};
};
/* Extract SNVs from somatic results
Type: snvs :: somatic results -> vcf
@@ -41,7 +41,7 @@ with types;
# result of callSomatic
drv: stage {
name = "strelka-callVariants-snvs";
- buildCommand = "ln -s ${drv}/variants/somatic.snvs.vcf.gz $out";
- passthru.filetype = filetype.gz (filetype.vcf {ref = ref;});
+ buildCommand = "ln -s ${drv}/variants/somatic.snvs.vcf $out";
+ passthru.filetype = filetype.vcf {ref = ref;};
};
}