aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix11
1 files changed, 8 insertions, 3 deletions
diff --git a/default.nix b/default.nix
index 43a2332..54d0215 100644
--- a/default.nix
+++ b/default.nix
@@ -78,8 +78,8 @@ let
lib = nixpkgs.lib // { types = types; shard = callBionix ./lib/shard.nix {};};
stage = x@{ name, stripStorePaths ? true, multicore ? false, ... }:
(if stripStorePaths then strip else x: x) (nixpkgs.stdenvNoCC.mkDerivation (x // {name = "bionix-" + name; inherit multicore;}));
- strip = drv: drv.overrideAttrs (attrs: {
- buildCommand = attrs.buildCommand + ''
+ strip = drv: let
+ stripCommand = ''
function rewrite {
sed -i 's|/nix/store/[^-]*|/nix/store/00000000000000000000000000000000|g' $1
@@ -97,7 +97,12 @@ let
rewriteOutput $o
done
'';
- });
+ in drv.overrideAttrs (attrs:
+ if attrs ? buildCommand then
+ {buildCommand = attrs.buildCommand + stripCommand;}
+ else
+ { fixupPhase = (if attrs ? fixupPhase then attrs.fixupPhase else "") + stripCommand; }
+ );
# splitting/joining
splitFile = file: drv: stage {