aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix8
1 files changed, 1 insertions, 7 deletions
diff --git a/default.nix b/default.nix
index 04fd62c..3ec0450 100644
--- a/default.nix
+++ b/default.nix
@@ -151,13 +151,7 @@ let
stripCommand = ''
function rewriteOutput {
- if [ -f ''${!1} ] ; then
- strip-store-paths ''${!1}
- else
- for f in $(find ''${!1} -type f) ; do
- strip-store-paths $f
- done
- fi
+ find ''${!1} -type f -print0 | xargs -0 -n1 strip-store-paths
}
for o in $outputs ; do
rewriteOutput $o