aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix6
1 files changed, 5 insertions, 1 deletions
diff --git a/default.nix b/default.nix
index 3ec0450..1c550b8 100644
--- a/default.nix
+++ b/default.nix
@@ -151,7 +151,11 @@ let
stripCommand = ''
function rewriteOutput {
- find ''${!1} -type f -print0 | xargs -0 -n1 strip-store-paths
+ if [ -f ''${!1} ] ; then
+ strip-store-paths ''${!1}
+ else
+ find ''${!1} -type f -print0 | xargs -0 -n1 strip-store-paths
+ fi
}
for o in $outputs ; do
rewriteOutput $o