aboutsummaryrefslogtreecommitdiff
path: root/examples/ex-tnpair/cluster.nix
diff options
context:
space:
mode:
Diffstat (limited to 'examples/ex-tnpair/cluster.nix')
-rw-r--r--examples/ex-tnpair/cluster.nix15
1 files changed, 8 insertions, 7 deletions
diff --git a/examples/ex-tnpair/cluster.nix b/examples/ex-tnpair/cluster.nix
index 5d4e1de..295d3eb 100644
--- a/examples/ex-tnpair/cluster.nix
+++ b/examples/ex-tnpair/cluster.nix
@@ -3,13 +3,14 @@
let
bionix = import <bionix> {
overlays = [
- (_: super:
- super."${if tmpDir == null then "slurm" else "qsub"}"
- {
- ppn = 24;
- mem = 7;
- walltime = "3:00:00";
- } // super.lib.optionalAttrs (tmpDir != null) { inherit tmpDir; })
+ (_: super: with super;
+ {
+ exec = f: def (slurm-exec f) {
+ ppn = 24;
+ mem = 7;
+ walltime = "3:00:00";
+ };
+ })
(self: super:
with super; {