aboutsummaryrefslogtreecommitdiff
path: root/examples/ex-tnpair/tnpair.nix
diff options
context:
space:
mode:
Diffstat (limited to 'examples/ex-tnpair/tnpair.nix')
-rw-r--r--examples/ex-tnpair/tnpair.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/examples/ex-tnpair/tnpair.nix b/examples/ex-tnpair/tnpair.nix
new file mode 100644
index 0000000..2939db4
--- /dev/null
+++ b/examples/ex-tnpair/tnpair.nix
@@ -0,0 +1,26 @@
+# This is an example tumour-normal calling pipeline using strelka
+{ bionix ? import <bionix> {}
+, normal
+, tumour
+, ref
+}:
+
+with bionix;
+with lib;
+
+let
+ input = mapAttrs (_: fetchFastQGZ);
+
+ preprocess = pipe [
+ input
+ (bwa.align { ref = fetchFastA ref; })
+ (samtools.fixmate {})
+ (samtools.sort {})
+ (samtools.markdup {})
+ ];
+
+in linkDrv [
+ (ln (strelka.call {} {normal = preprocess normal; tumour = preprocess tumour;}) "strelka")
+ (ln (preprocess normal) "normal.bam")
+ (ln (preprocess tumour) "tumour.bam")
+]