aboutsummaryrefslogtreecommitdiff
path: root/examples/ex-tnpair/tnpair.nix
diff options
context:
space:
mode:
Diffstat (limited to 'examples/ex-tnpair/tnpair.nix')
-rw-r--r--examples/ex-tnpair/tnpair.nix10
1 files changed, 5 insertions, 5 deletions
diff --git a/examples/ex-tnpair/tnpair.nix b/examples/ex-tnpair/tnpair.nix
index c42fe95..ada96c8 100644
--- a/examples/ex-tnpair/tnpair.nix
+++ b/examples/ex-tnpair/tnpair.nix
@@ -19,8 +19,8 @@ let
(samtools.markdup {})
];
-in linkDrv [
- (ln (strelka.callSomatic {} {normal = preprocess normal; tumour = preprocess tumour;}) "strelka")
- (ln (preprocess normal) "normal.bam")
- (ln (preprocess tumour) "tumour.bam")
-]
+in linkOutputs {
+ strelka = strelka.callSomatic {} {normal = preprocess normal; tumour = preprocess tumour;};
+ "normal.bam" = preprocess normal;
+ "tumour.bam" = preprocess tumour;
+}