aboutsummaryrefslogtreecommitdiff
path: root/examples/ex-wdl/wdl-scatter-gather.nix
diff options
context:
space:
mode:
Diffstat (limited to 'examples/ex-wdl/wdl-scatter-gather.nix')
-rw-r--r--examples/ex-wdl/wdl-scatter-gather.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/examples/ex-wdl/wdl-scatter-gather.nix b/examples/ex-wdl/wdl-scatter-gather.nix
new file mode 100644
index 0000000..387d382
--- /dev/null
+++ b/examples/ex-wdl/wdl-scatter-gather.nix
@@ -0,0 +1,33 @@
+# The scatter-gather example from https://github.com/openwdl/wdl
+# translated to bionix
+{ bionix ? import <bionix> {} }:
+
+with bionix;
+with lib;
+
+let
+
+ prepare = splitString "\n" (removeSuffix "\n" (readFile (stage {
+ name = "prepare";
+ buildInputs = [ pkgs.python3 ];
+ buildCommand = ''
+ python -c "print('one\ntwo\nthree\nfour', end=''')" > $out
+ '';
+ })));
+
+ analysis = str: removeSuffix "\n" (readFile (stage {
+ name = "analysis";
+ buildInputs = [ pkgs.python ];
+ buildCommand = ''
+ python -c "print('_${str}_')" > $out
+ '';
+ }));
+
+ gather = strs: stage {
+ name = "gather";
+ buildCommand = ''
+ echo ${concatStringsSep " " strs} > $out
+ '';
+ };
+
+in gather (map analysis prepare)