aboutsummaryrefslogtreecommitdiff
path: root/examples/tnpair.nix
diff options
context:
space:
mode:
Diffstat (limited to 'examples/tnpair.nix')
-rw-r--r--examples/tnpair.nix26
1 files changed, 0 insertions, 26 deletions
diff --git a/examples/tnpair.nix b/examples/tnpair.nix
deleted file mode 100644
index 2939db4..0000000
--- a/examples/tnpair.nix
+++ /dev/null
@@ -1,26 +0,0 @@
-# This is an example tumour-normal calling pipeline using strelka
-{ bionix ? import <bionix> {}
-, normal
-, tumour
-, ref
-}:
-
-with bionix;
-with lib;
-
-let
- input = mapAttrs (_: fetchFastQGZ);
-
- preprocess = pipe [
- input
- (bwa.align { ref = fetchFastA ref; })
- (samtools.fixmate {})
- (samtools.sort {})
- (samtools.markdup {})
- ];
-
-in linkDrv [
- (ln (strelka.call {} {normal = preprocess normal; tumour = preprocess tumour;}) "strelka")
- (ln (preprocess normal) "normal.bam")
- (ln (preprocess tumour) "tumour.bam")
-]