aboutsummaryrefslogtreecommitdiff
path: root/lib/shard.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lib/shard.nix')
-rw-r--r--lib/shard.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/lib/shard.nix b/lib/shard.nix
index 95cf251..9b85027 100644
--- a/lib/shard.nix
+++ b/lib/shard.nix
@@ -1,9 +1,9 @@
-{bionix}:
+{ bionix }:
with bionix;
with lib.types;
{
- regex = n: input: outputDrvs (callBionixE ./shard-regex.nix { n = n; } input);
- fastQPair = n: {input1, input2}: lib.zipListsWith (i: j: {input1 = i; input2 = j;}) (lib.shard.regex n input1) (lib.shard.regex n input2);
+ regex = n: input: outputDrvs (callBionixE ./shard-regex.nix { inherit n; } input);
+ fastQPair = n: { input1, input2 }: lib.zipListsWith (i: j: { input1 = i; input2 = j; }) (lib.shard.regex n input1) (lib.shard.regex n input2);
}