aboutsummaryrefslogtreecommitdiff
path: root/strip-store-paths/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'strip-store-paths/default.nix')
-rw-r--r--strip-store-paths/default.nix5
1 files changed, 3 insertions, 2 deletions
diff --git a/strip-store-paths/default.nix b/strip-store-paths/default.nix
index 40fb546..473df87 100644
--- a/strip-store-paths/default.nix
+++ b/strip-store-paths/default.nix
@@ -4,14 +4,15 @@ stdenv.mkDerivation {
name = "strip-store-paths";
nativeBuildInputs = [ zig ];
src = ./strip-store-paths.zig;
+
+ XDG_CACHE_HOME = "Cache";
unpackPhase = ''
cp $src strip-store-paths.zig
'';
buildPhase = ''
- export HOME=$TMPDIR
- zig build-exe -OReleaseFast strip-store-paths.zig
+ zig build-exe -OReleaseFast -mcpu=baseline strip-store-paths.zig
'';
installPhase = ''