aboutsummaryrefslogtreecommitdiff
path: root/tools/bowtie.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tools/bowtie.nix')
-rw-r--r--tools/bowtie.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/tools/bowtie.nix b/tools/bowtie.nix
index a4439d3..df97d36 100644
--- a/tools/bowtie.nix
+++ b/tools/bowtie.nix
@@ -3,6 +3,13 @@
with bionix;
{
+ /* Align a sequence against a reference
+ Type: align :: {ref :: fasta, bamOutput :: bool, ...} -> {input1 :: fastq, input2 :: fastq} -> bam/sam
+ */
align = callBionixE ./bowtie-align.nix;
+
+ /* Create a Bowtie index
+ Type: index :: {seed :: int, ...} -> fasta -> index
+ */
index = callBionixE ./bowtie-index.nix;
}