aboutsummaryrefslogtreecommitdiff
path: root/tools/bwa-mem2-app.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tools/bwa-mem2-app.nix')
-rw-r--r--tools/bwa-mem2-app.nix33
1 files changed, 18 insertions, 15 deletions
diff --git a/tools/bwa-mem2-app.nix b/tools/bwa-mem2-app.nix
index 8cca5a5..b303485 100644
--- a/tools/bwa-mem2-app.nix
+++ b/tools/bwa-mem2-app.nix
@@ -1,15 +1,18 @@
-{ bwa, fetchFromGitHub }:
- bwa.overrideAttrs (_:
- {
- name = "bwa-mem2";
- src = fetchFromGitHub {
- owner = "bwa-mem2";
- repo = "bwa-mem2";
- rev = "f882015f7f46845f72c10094a621264f78d206d8";
- sha256 = "1wfx8j9mwbb29jw4zxp28lajmj774jy1l5x229nf065cqr2dgyqg";
- };
- installPhase = ''
- mkdir -p $out/bin
- cp bwa-mem2 $out/bin
- '';
- })
+{ clangStdenv, fetchFromGitHub, zlib }:
+ clangStdenv.mkDerivation rec {
+ pname = "bwa-mem2";
+ version = "2.0";
+ src = fetchFromGitHub {
+ fetchSubmodules = true;
+ owner = "bwa-mem2";
+ repo = "bwa-mem2";
+ rev = "v${version}";
+ sha256 = "0q5wqal0nfxd3yfbmxahyaiqqmsrrplnwhplcjvz1xzw7bxwwnnj";
+ };
+ buildInputs = [ zlib ];
+ installPhase = ''
+ mkdir -p $out/bin
+ cp bwa-mem2 $out/bin
+ '';
+ disableHardening = [ "pie" ];
+}