aboutsummaryrefslogtreecommitdiff
path: root/tools/bwa-mem2.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tools/bwa-mem2.nix')
-rw-r--r--tools/bwa-mem2.nix2
1 files changed, 2 insertions, 0 deletions
diff --git a/tools/bwa-mem2.nix b/tools/bwa-mem2.nix
index 843c5b0..e6237f0 100644
--- a/tools/bwa-mem2.nix
+++ b/tools/bwa-mem2.nix
@@ -3,6 +3,7 @@
, bamOutput ? true
, flags ? null
, indexAttrs ? { }
+, RG ? { }
}:
{ input1
@@ -33,6 +34,7 @@ stage {
fi
bwa-mem2 mem ${optionalString (flags != null) flags} -t $cores ref.fa ${fq input1} \
${optionalString (input2 != null) (fq input2)} \
+ ${optionalString (RG ? ID) "-R'@RG\\t${concatMapAttrsStringsSep "\\t" (k: v: "${k}:${v}") RG}'"} \
${optionalString bamOutput "| samtools view -b"} \
> $out
'';