aboutsummaryrefslogtreecommitdiff
path: root/tools/fastp.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tools/fastp.nix')
-rw-r--r--tools/fastp.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/tools/fastp.nix b/tools/fastp.nix
index 90f6c1d..551d270 100644
--- a/tools/fastp.nix
+++ b/tools/fastp.nix
@@ -4,6 +4,10 @@ with bionix;
rec {
app = pkgs.callPackage ./fastp-app.nix {};
+
+ /* Check and filter fastqs
+ Type: { ... } -> { input1, input2 ? null } -> { out :: html, fastq1 :: fastq, fastq2 :: fastq, json :: JSON }
+ */
check = callBionixE ./fastp-check.nix;
}