aboutsummaryrefslogtreecommitdiff
path: root/tools/fastqc-check.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tools/fastqc-check.nix')
-rw-r--r--tools/fastqc-check.nix12
1 files changed, 6 insertions, 6 deletions
diff --git a/tools/fastqc-check.nix b/tools/fastqc-check.nix
index 1d9993a..17d6183 100644
--- a/tools/fastqc-check.nix
+++ b/tools/fastqc-check.nix
@@ -1,16 +1,16 @@
-{ stdenv
-, lib
-, callPackage
-, fastqc ? callPackage ./fastqc-app.nix {}
-, flags ? null}:
+{ bionix
+, nixpkgs
+, flags ? null
+}:
+with nixpkgs;
with lib;
input:
stdenv.mkDerivation {
name = "fastqc-check";
- buildInputs = [ fastqc ];
+ buildInputs = [ bionix.fastqc.fastqc ];
buildCommand = ''
mkdir $out
fastqc \