aboutsummaryrefslogtreecommitdiff
path: root/tools/genmap-calcmap.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tools/genmap-calcmap.nix')
-rw-r--r--tools/genmap-calcmap.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/tools/genmap-calcmap.nix b/tools/genmap-calcmap.nix
new file mode 100644
index 0000000..df9ccc3
--- /dev/null
+++ b/tools/genmap-calcmap.nix
@@ -0,0 +1,22 @@
+{ bionix
+, k ? 30
+, e ? 2
+}:
+
+with bionix;
+
+ref: stage {
+ name = "genmap-mappability";
+ buildInputs = with pkgs; [ genmap ];
+ buildCommand = ''
+ mkdir $out
+ genmap map \
+ -K ${toString k} \
+ -E ${toString e} \
+ --wig \
+ -I ${bionix.genmap.index {} ref} \
+ -O $out \
+ -T $NIX_BUILD_CORES
+ '';
+ passthru.multicore = true;
+}