aboutsummaryrefslogtreecommitdiff
path: root/tools/genmap-index.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tools/genmap-index.nix')
-rw-r--r--tools/genmap-index.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/tools/genmap-index.nix b/tools/genmap-index.nix
new file mode 100644
index 0000000..249f061
--- /dev/null
+++ b/tools/genmap-index.nix
@@ -0,0 +1,16 @@
+{ bionix }:
+
+with bionix;
+with lib.types;
+
+let
+ fa = f: matchFiletype "genmap-index" { fa = _: f; } f;
+in
+
+ref: stage {
+ name = "genmap-index";
+ buildInputs = with pkgs; [ genmap ];
+ buildCommand = ''
+ genmap index -F ${fa ref} -I $out
+ '';
+}