aboutsummaryrefslogtreecommitdiff
path: root/tools/gridss.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tools/gridss.nix')
-rw-r--r--tools/gridss.nix3
1 files changed, 3 insertions, 0 deletions
diff --git a/tools/gridss.nix b/tools/gridss.nix
index aaf8e16..41f6a5a 100644
--- a/tools/gridss.nix
+++ b/tools/gridss.nix
@@ -43,6 +43,9 @@ rec {
Type: assemble :: {config :: ini = null, heapSize :: String = "31g", ...} -> [bam] -> bam
*/
assemble = callBionixE ./gridss-assemble.nix;
+ shardedAssemble = n: a: input:
+ let assemblies = genList (i: bionix.gridss.assemble (a // { jobNodes = n; jobIndex = i;}) input) n;
+ in if n <= 1 then bionix.gridss.assemble a input else bionix.gridss.assemble (a // {workdirs = map (a: a.work) assemblies;}) input;
/* Invoke identifyVariants tool
Type: identifyVariants :: {config :: ini = null, heapSize :: String = "4g", ...} -> [bam] -> VCF