aboutsummaryrefslogtreecommitdiff
path: root/tools/octopus-call.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tools/octopus-call.nix')
-rw-r--r--tools/octopus-call.nix3
1 files changed, 3 insertions, 0 deletions
diff --git a/tools/octopus-call.nix b/tools/octopus-call.nix
index 1688d88..f33d87c 100644
--- a/tools/octopus-call.nix
+++ b/tools/octopus-call.nix
@@ -28,6 +28,7 @@ assert (length (unique refs) == 1);
stage {
name = "octopus-call";
buildInputs = with pkgs; [ octopus-caller ];
+ outputs = [ "out" "evidence" ];
buildCommand = ''
ln -s ${ref} ref.fa
ln -s ${samtools.faidx faidxAttrs ref} ref.fai
@@ -35,7 +36,9 @@ stage {
ln -s ${i} $(basename ${i}).bam
ln -s ${samtools.index indexAttrs i} $(basename ${i}).bai
'') inputs}
+ ${optionalString (length inputs > 1) "mkdir $evidence"}
octopus -R ref.fa -I *.bam -o $out \
+ --bamout $evidence \
--threads=$NIX_BUILD_CORES \
${optionalString fast "--fast"} \
${optionalString very-fast "--very-fast"} \