aboutsummaryrefslogtreecommitdiff
path: root/tools/octopus-callSomatic.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tools/octopus-callSomatic.nix')
-rw-r--r--tools/octopus-callSomatic.nix3
1 files changed, 3 insertions, 0 deletions
diff --git a/tools/octopus-callSomatic.nix b/tools/octopus-callSomatic.nix
index 5c2ca90..d3e7f96 100644
--- a/tools/octopus-callSomatic.nix
+++ b/tools/octopus-callSomatic.nix
@@ -42,6 +42,7 @@ assert (length (unique refs) == 1);
stage {
name = "octopus-callSomatic";
buildInputs = with pkgs; [ octopus-caller samtools ];
+ outputs = [ "out" "evidence" ];
buildCommand = ''
ln -s ${ref} ref.fa
ln -s ${samtools.faidx faidxAttrs ref} ref.fai
@@ -50,7 +51,9 @@ stage {
ln -s ${samtools.index indexAttrs i} $(basename ${i}).bai
'') inputs}
normal=$(samtools view -H ${normal} | awk -f ${smScript})
+ mkdir $evidence
octopus -R ref.fa -I *.bam -o $out \
+ --bamout $evidence \
--threads=$NIX_BUILD_CORES \
${optionalString fast "--fast"} \
${optionalString very-fast "--very-fast"} \