aboutsummaryrefslogtreecommitdiff
path: root/tools/samtools-dict.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tools/samtools-dict.nix')
-rw-r--r--tools/samtools-dict.nix9
1 files changed, 4 insertions, 5 deletions
diff --git a/tools/samtools-dict.nix b/tools/samtools-dict.nix
index 80ec1e0..f9de70f 100644
--- a/tools/samtools-dict.nix
+++ b/tools/samtools-dict.nix
@@ -1,19 +1,18 @@
{ bionix
-, nixpkgs
, flags ? null
}:
input:
-with nixpkgs;
+with bionix;
with lib;
-with bionix.types;
+with types;
assert (matchFiletype "samtools-dict" { fa = _: true; } input);
-stdenv.mkDerivation {
+stage {
name = "samtools-dict";
- buildInputs = [ samtools ];
+ buildInputs = with pkgs; [ samtools ];
buildCommand = ''
samtools dict ${optionalString (flags != null) flags} ${input} > $out
'';