aboutsummaryrefslogtreecommitdiff
path: root/tools/samtools-index.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tools/samtools-index.nix')
-rw-r--r--tools/samtools-index.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/tools/samtools-index.nix b/tools/samtools-index.nix
index 4e09dc7..aad46a7 100644
--- a/tools/samtools-index.nix
+++ b/tools/samtools-index.nix
@@ -7,6 +7,10 @@ input:
with nixpkgs;
with lib;
+with bionix.types;
+
+assert (matchFiletype "samtools-index" { bam = _: true; } input);
+assert (matchSorting "samtools-index" { coord = _: true; } input);
stdenv.mkDerivation {
name = "samtools-index";