aboutsummaryrefslogtreecommitdiff
path: root/tools/samtools-tabix.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tools/samtools-tabix.nix')
-rw-r--r--tools/samtools-tabix.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/tools/samtools-tabix.nix b/tools/samtools-tabix.nix
new file mode 100644
index 0000000..a493b9d
--- /dev/null
+++ b/tools/samtools-tabix.nix
@@ -0,0 +1,22 @@
+{ bionix
+, flags ? null
+}:
+
+input:
+
+with bionix;
+with lib;
+with types;
+
+assert (matchFiletype "samtools-tabix" { bgz = _: true; } input);
+
+stage {
+
+ name = "samtools-tabix";
+ buildInputs = with pkgs; [ htslib ];
+ buildCommand = ''
+ ln -s ${input} input.bgz
+ tabix input.bgz
+ cp input.bgz.tbi $out
+ '';
+}