aboutsummaryrefslogtreecommitdiff
path: root/tools/strelka-call.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tools/strelka-call.nix')
-rw-r--r--tools/strelka-call.nix13
1 files changed, 12 insertions, 1 deletions
diff --git a/tools/strelka-call.nix b/tools/strelka-call.nix
index 7836bbe..bc1e202 100644
--- a/tools/strelka-call.nix
+++ b/tools/strelka-call.nix
@@ -38,7 +38,18 @@ stage {
-m local \
-j $NIX_BUILD_CORES 2>&1
- cp -r results $out
+ # Strelka writes runtime stats and timestamps;
+ # both have to be stripped to provide determinism
+ cd results/variants
+ rm *.tbi genome.vcf.gz
+ for f in *.vcf.gz; do
+ gunzip $f
+ g=$(basename $f .gz)
+ sed -i '/^##fileDate/d' $g
+ sed -i '/^##startTime/d' $g
+ done
+ mkdir $out
+ cp -r * $out
'';
passthru.multicore = true;
}