aboutsummaryrefslogtreecommitdiff
path: root/tools/subread-index.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tools/subread-index.nix')
-rw-r--r--tools/subread-index.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/tools/subread-index.nix b/tools/subread-index.nix
new file mode 100644
index 0000000..a5177a1
--- /dev/null
+++ b/tools/subread-index.nix
@@ -0,0 +1,20 @@
+{ bionix
+, flags ? null
+}:
+
+ref:
+
+with bionix;
+with lib;
+with types;
+
+assert (matchFiletype "subread-index" { fa = _: true; } ref);
+
+stage {
+ name = "subread-index";
+ buildInputs = with pkgs; [ subread ];
+ buildCommand = ''
+ mkdir $out
+ subread-buildindex ${optionalString (flags != null) flags} -o $out/ref ${ref}
+ '';
+}