aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2021-08-02 21:41:57 +1000
committerJustin Bedo <cu@cua0.org>2021-08-02 21:49:50 +1000
commitefd9fcdbbd3a961e97bb3d02ae086c258c1ecb40 (patch)
treec478fc2bfa79e6383b6395c3a9eda1b53e1408b6 /default.nix
initial implementation
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/default.nix b/default.nix
new file mode 100644
index 0000000..a468bbe
--- /dev/null
+++ b/default.nix
@@ -0,0 +1,26 @@
+{ lib, stdenvNoCC, fzf, libxml2, makeWrapper }:
+
+stdenvNoCC.mkDerivation {
+ pname = "clinvar";
+ version = "0.1";
+
+ src = ./.;
+
+ nativeBuildInputs = [ makeWrapper ];
+
+ installPhase = ''
+ runHook preInstall
+ install -Dm 755 clinvar $out/bin/clinvar
+ install -Dm 644 clinvar.1 $out/bin/man/man1/clinvar.1
+ runHook postInstall
+ '';
+
+ fixupPhase = ''
+ runHook preFixup
+ wrapProgram $out/bin/clinvar \
+ --prefix PATH : "${lib.makeBinPath [ fzf libxml2 ]}"
+ runHook postFixup
+ '';
+
+ meta.mainProgram = "clinvar";
+}