aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2021-08-02 21:41:57 +1000
committerJustin Bedo <cu@cua0.org>2021-08-02 21:49:50 +1000
commitefd9fcdbbd3a961e97bb3d02ae086c258c1ecb40 (patch)
treec478fc2bfa79e6383b6395c3a9eda1b53e1408b6 /flake.nix
initial implementation
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..d267b4d
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,12 @@
+{
+ inputs.flake-utils.url = "github:numtide/flake-utils";
+
+ outputs = { nixpkgs, flake-utils, self }:
+ flake-utils.lib.eachDefaultSystem (system:
+ let pkgs = nixpkgs.legacyPackages.${system};
+ in rec {
+ packages =
+ flake-utils.lib.flattenTree { clinvar = pkgs.callPackage ./. { }; };
+ defaultPackage = packages.clinvar;
+ });
+}