summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2023-02-07 15:27:42 +1100
committerJustin Bedo <cu@cua0.org>2023-02-07 17:08:50 +1100
commita0b5f58d8d2040306006a8b9deded629692ed8f3 (patch)
tree9c04ed6efabf67e9bb6b1f8f7ae9029c3b46587a /meson.build
init
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/meson.build b/meson.build
new file mode 100644
index 0000000..0145c5a
--- /dev/null
+++ b/meson.build
@@ -0,0 +1,7 @@
+project('coda-pca', 'c',
+ version : '0.1',
+ default_options : ['warning_level=3'])
+cc = meson.get_compiler('c')
+m_dep = cc.find_library('m', required : false)
+install_headers('pca.h')
+shared_library('codapca', 'pca.c', dependencies : m_dep, install : true)