summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..f374de4
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,8 @@
+cmake_minimum_required(VERSION 3.4)
+project(genodict)
+find_package(ZLIB)
+add_executable(dict dict.c dict.h)
+add_executable(dot dot.c dict.h)
+target_link_libraries(dict ${ZLIB_LIBRARIES})
+target_link_libraries(dot m)
+set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -march=native -O3")