summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2024-10-10 09:52:43 +1100
committerJustin Bedo <cu@cua0.org>2024-10-10 10:04:51 +1100
commit83d02e27ac3a4b87761fa9bd79520aa3161b8b91 (patch)
tree085db65abe98ce545907644c08e0aac6979b2740 /flake.nix
initial prototype
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..fec219d
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,10 @@
+{
+ inputs.nixpkgs.url = "github:nixos/nixpkgs";
+ outputs = {self, nixpkgs}:
+ let
+ system = "x86_64-linux";
+ pkgs = import nixpkgs {inherit system;};
+ in {
+ packages.${system}.default = pkgs.haskellPackages.callCabal2nix "jterm" ./. {};
+ };
+}