aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2022-02-11 11:50:36 +1100
committerJustin Bedo <cu@cua0.org>2022-02-11 11:55:05 +1100
commitcca7a01d0f83b61f12491db0923e502c5650b918 (patch)
treef4e90ddaa9b4fceec6703e188196daa54f5e0a59 /flake.nix
init
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..951ec9e
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,20 @@
+{
+ inputs = {
+ nixpkgs.url = "github:nixos/nixpkgs";
+ flake-utils.url = "github:numtide/flake-utils";
+ };
+
+ outputs =
+ { nixpkgs
+ , flake-utils
+ , self
+ }:
+ flake-utils.lib.eachDefaultSystem (
+ system: let
+ pkgs = import nixpkgs { inherit system; };
+ in
+ {
+ defaultPackage = pkgs.callPackage ./. { };
+ }
+ );
+}