summaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/default.nix b/default.nix
new file mode 100644
index 0000000..0a9f8b6
--- /dev/null
+++ b/default.nix
@@ -0,0 +1,23 @@
+{pkgs ? import <nixpkgs> {}}:
+with pkgs; let
+ ghc = haskellPackages.ghcWithPackages (ps:
+ with ps; [
+ lens-aeson
+ wreq
+ sqlite-simple
+ PyF
+ optparse-applicative
+ ]);
+in
+ stdenv.mkDerivation {
+ name = "mavedb-scraper";
+ src = ./src;
+
+ buildInputs = [ghc];
+
+ buildPhase = ''
+ ghc -o scrape *.hs -O -rtsopts -threaded
+ '';
+
+ installPhase = "install -Dm755 ./scrape $out/bin/scrape";
+ }