aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2022-12-16 10:57:55 +1100
committerJustin Bedo <cu@cua0.org>2022-12-31 17:28:29 +1100
commite318b40cfc1a3079375a015a651b1b44f6279ad0 (patch)
tree40a72f1b807fd77a1dd53ebf3f0cc284e65f30ad /flake.nix
init
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix39
1 files changed, 39 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..76c754c
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,39 @@
+{
+ nixConfig = {
+ extra-trusted-public-keys = ["hydra.iohk.io:f/Ea+s+dFdN+3Y/G+FDgSq+a5NEWhJGzdjvKNGv0/EQ="];
+ extra-substituters = ["https://cache.iog.io"];
+ };
+ description = "Bayesian phylogentic playground";
+ inputs.haskellNix.url = "github:input-output-hk/haskell.nix";
+ inputs.nixpkgs.follows = "haskellNix/nixpkgs-unstable";
+ inputs.flake-utils.url = "github:numtide/flake-utils";
+ outputs = {
+ self,
+ nixpkgs,
+ flake-utils,
+ haskellNix,
+ }:
+ flake-utils.lib.eachSystem ["x86_64-linux"] (system: let
+ overlays = [
+ haskellNix.overlay
+ (final: prev: {
+ phylogenies = final.haskell-nix.project' {
+ src = ./.;
+ compiler-nix-name = "ghc925";
+ shell.tools = {
+ hlint = {};
+ ormolu = {};
+ };
+ shell.buildInputs = with pkgs; [
+ ];
+ };
+ })
+ ];
+ pkgs = import nixpkgs {
+ inherit system overlays;
+ inherit (haskellNix) config;
+ };
+ flake = pkgs.phylogenies.flake {};
+ in
+ flake // { packages.default = flake.packages."ppl:lib:ppl";});
+}