aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/flake.nix b/flake.nix
index 76c754c..9a12c04 100644
--- a/flake.nix
+++ b/flake.nix
@@ -3,7 +3,7 @@
extra-trusted-public-keys = ["hydra.iohk.io:f/Ea+s+dFdN+3Y/G+FDgSq+a5NEWhJGzdjvKNGv0/EQ="];
extra-substituters = ["https://cache.iog.io"];
};
- description = "Bayesian phylogentic playground";
+ description = "Probabilistic Programming Language";
inputs.haskellNix.url = "github:input-output-hk/haskell.nix";
inputs.nixpkgs.follows = "haskellNix/nixpkgs-unstable";
inputs.flake-utils.url = "github:numtide/flake-utils";
@@ -17,7 +17,7 @@
overlays = [
haskellNix.overlay
(final: prev: {
- phylogenies = final.haskell-nix.project' {
+ ppl = final.haskell-nix.project' {
src = ./.;
compiler-nix-name = "ghc925";
shell.tools = {
@@ -33,7 +33,7 @@
inherit system overlays;
inherit (haskellNix) config;
};
- flake = pkgs.phylogenies.flake {};
+ flake = pkgs.ppl.flake {};
in
flake // { packages.default = flake.packages."ppl:lib:ppl";});
}