aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2024-10-14 10:06:54 +1100
committerJustin Bedo <cu@cua0.org>2024-10-14 10:06:54 +1100
commit62e78dd44e17d26b7b93c6d13ec2894aa507d14a (patch)
treee8313b62738e867a4cf38e4f8f594f322809b82f /flake.nix
parent204508bd0db9ac4e4c43798a56f67157c7fc07bc (diff)
add nix expressions
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..7937fc0
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,10 @@
+{
+ inputs.nixpkgs.url = "github:nixos/nixpkgs";
+ outputs = {self, nixpkgs}:
+ let
+ system = "x86_64-linux";
+ pkgs = import nixpkgs {inherit system;};
+ in {
+ packages.${system}.default = pkgs.callPackage ./. {};
+ };
+}