summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2022-11-21 09:39:44 +1100
committerJustin Bedo <cu@cua0.org>2022-11-21 16:59:38 +1100
commit4f427f345fb703c5db7ac01eb440a69cce09872b (patch)
tree72d3d7847468db64067982e13d1c78ff018fef59 /flake.nix
init
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..42dfd89
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,20 @@
+{
+ description = "Slides for Bioinformatics division talk 2022";
+ inputs = {
+ nixpkgs.url = "github:nixos/nixpkgs";
+ flake-utils.url = "github:numtide/flake-utils";
+ };
+
+ outputs = {
+ self,
+ nixpkgs,
+ flake-utils,
+ }:
+ flake-utils.lib.eachDefaultSystem (system: let
+ pkgs = import nixpkgs {inherit system;};
+ in {
+ devShell = pkgs.mkShell {
+ buildInputs = with pkgs; [biber pkgs.texlive.combined.scheme-full];
+ };
+ });
+}