aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2021-07-29 16:47:54 +1000
committerJustin Bedo <cu@cua0.org>2021-07-29 16:47:54 +1000
commit6bd9f1715fc2e1d4548046e3ce2bd91d64625a1e (patch)
treebb557c5ab200f0f7a691e737b59b5044177e0c04 /shell.nix
parent7c29ef494f974b457bfef6a5af7d37fa03bb7952 (diff)
convert nix expressions to flakes
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix19
1 files changed, 10 insertions, 9 deletions
diff --git a/shell.nix b/shell.nix
index 40ee189..339bb5d 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,12 +1,13 @@
-let
- pkgs = import <nixpkgs> { };
+{ mkShell, ghc, haskell, biohazardSrc }:
- ghc = with pkgs.haskell.lib;
- pkgs.ghc.withPackages (pkgs:
- with pkgs;
- [
+let
+ ghcP = with haskell.lib;
+ ghc.withPackages (pkgs:
+ with pkgs; [
hlint
- (doJailbreak (markUnbroken
- (biohazard.overrideAttrs (_: { patches = [ ./biohazard.patch ]; }))))
+ (doJailbreak (markUnbroken (biohazard.overrideAttrs (_: {
+ src = biohazardSrc;
+ patches = [ ./biohazard.patch ];
+ }))))
]);
-in pkgs.mkShell { buildInputs = [ ghc ]; }
+in mkShell { buildInputs = [ ghcP ]; }