aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix14
1 files changed, 7 insertions, 7 deletions
diff --git a/default.nix b/default.nix
index 3314d66..638cbcc 100644
--- a/default.nix
+++ b/default.nix
@@ -1,16 +1,16 @@
-let
- pkgs = import <nixpkgs> { };
+{ stdenv, ghc, haskell, biohazardSrc }:
- ghc = with pkgs.haskell.lib;
- pkgs.ghc.withPackages (pkgs:
+let
+ ghcP = with haskell.lib;
+ ghc.withPackages (pkgs:
with pkgs;
[
(doJailbreak (markUnbroken
- (biohazard.overrideAttrs (_: { patches = [ ./biohazard.patch ]; }))))
+ (biohazard.overrideAttrs (_: { src = biohazardSrc; patches = [ ./biohazard.patch ];}))))
]);
-in pkgs.stdenv.mkDerivation {
+in stdenv.mkDerivation {
name = "xenomapper-hs";
- buildInputs = [ ghc ];
+ buildInputs = [ ghcP ];
src = ./.;
buildPhase = ''
ghc -O3 xenomapper.hs -o xenomapper