aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..40ee189
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,12 @@
+let
+ pkgs = import <nixpkgs> { };
+
+ ghc = with pkgs.haskell.lib;
+ pkgs.ghc.withPackages (pkgs:
+ with pkgs;
+ [
+ hlint
+ (doJailbreak (markUnbroken
+ (biohazard.overrideAttrs (_: { patches = [ ./biohazard.patch ]; }))))
+ ]);
+in pkgs.mkShell { buildInputs = [ ghc ]; }