aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2022-01-06 13:24:35 +1100
committerJustin Bedo <cu@cua0.org>2022-01-06 13:24:35 +1100
commit51951403ec33c415df715d8db5ebfcd0bbebcb7f (patch)
treeeec9303f76acdfa68df1f7ca7c56b6b4e31145ca /default.nix
parentcc7f641de6517706742875f2ec4e09b12ab0a6d4 (diff)
strip-store-paths: allow no files
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix6
1 files changed, 1 insertions, 5 deletions
diff --git a/default.nix b/default.nix
index 1c550b8..3ec0450 100644
--- a/default.nix
+++ b/default.nix
@@ -151,11 +151,7 @@ let
stripCommand = ''
function rewriteOutput {
- if [ -f ''${!1} ] ; then
- strip-store-paths ''${!1}
- else
- find ''${!1} -type f -print0 | xargs -0 -n1 strip-store-paths
- fi
+ find ''${!1} -type f -print0 | xargs -0 -n1 strip-store-paths
}
for o in $outputs ; do
rewriteOutput $o