aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2019-05-16 21:18:27 +1000
committerJustin Bedo <cu@cua0.org>2019-05-16 21:46:02 +1000
commitd5fd734513671d957c20a66655c98d325bb1760f (patch)
treedf0ab9cf8b9806f939723cb2e0827aa047185948 /default.nix
parentfa35a2634108bd179de0c7dd21ca5355f6918a9b (diff)
slurm: renamed from sbatch
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/default.nix b/default.nix
index 575d176..15b8d87 100644
--- a/default.nix
+++ b/default.nix
@@ -36,10 +36,10 @@ let
ascat = callBionix ./tools/ascat.nix {};
fastp = callBionix ./tools/fastp.nix {};
- sbatch = attrs: bionix.extend (self: super: with self; rec {
- sbatchDefs = { ppn = 1; mem = 1; walltime = "24:00:00"; partition = null; slurmFlags = null; } // attrs;
- sbatch = attrs: (callPackage ./lib/sbatch.nix {}) (sbatchDefs // attrs);
- exec = f: x: y: sbatch (builtins.intersectAttrs sbatchDefs x) (f (builtins.removeAttrs x (builtins.attrNames sbatchDefs)) y);
+ slurm = attrs: bionix.extend (self: super: with self; rec {
+ slurmDefs = { ppn = 1; mem = 1; walltime = "24:00:00"; partition = null; slurmFlags = null; } // attrs;
+ slurm = attrs: (callPackage ./lib/slurm.nix {}) (slurmDefs // attrs);
+ exec = f: x: y: slurm (builtins.intersectAttrs slurmDefs x) (f (builtins.removeAttrs x (builtins.attrNames slurmDefs)) y);
});
qsub = attrs: bionix.extend (self: super: with self; rec {
qsubDefs = { ppn = 1; mem = 1; walltime = "24:00:00"; tmpDir = "/tmp"; sleepTime = 60; queue = null; qsubFlags = null; } // attrs;