aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2021-12-06 17:23:47 +1100
committerJustin Bedo <cu@cua0.org>2021-12-06 17:23:47 +1100
commitd75b723281aea944fbafdb28f5b0841a03827b4a (patch)
tree1b3b8a6103ed6547d00b1e3e1b61b08038e08a27 /default.nix
parent18d442a951dc36a352c13c604642cb3d4db5a6b6 (diff)
parameterise RG line as nix attribute set
Allows more seamless transitioning between alingment algorithms
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/default.nix b/default.nix
index db5d14f..6f6fb3d 100644
--- a/default.nix
+++ b/default.nix
@@ -109,7 +109,7 @@ let
'';
in
''
- mkdir $out
+ mkdir $out
'' + (concatStringsSep "\n" (mapAttrsToList link x));
passthru.linkInputs = x;
};
@@ -136,6 +136,7 @@ let
lib = nixpkgs.lib // {
inherit types;
shard = callBionix ./lib/shard.nix { };
+ concatMapAttrsStringsSep = s: f: a: with nixpkgs.lib; concatStringsSep s (mapAttrsToList f a);
};
stage = x@{ name, stripStorePaths ? true, multicore ? false, ... }:
(if stripStorePaths then strip else x: x)