aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/default.nix b/default.nix
index db5d14f..6f6fb3d 100644
--- a/default.nix
+++ b/default.nix
@@ -109,7 +109,7 @@ let
'';
in
''
- mkdir $out
+ mkdir $out
'' + (concatStringsSep "\n" (mapAttrsToList link x));
passthru.linkInputs = x;
};
@@ -136,6 +136,7 @@ let
lib = nixpkgs.lib // {
inherit types;
shard = callBionix ./lib/shard.nix { };
+ concatMapAttrsStringsSep = s: f: a: with nixpkgs.lib; concatStringsSep s (mapAttrsToList f a);
};
stage = x@{ name, stripStorePaths ? true, multicore ? false, ... }:
(if stripStorePaths then strip else x: x)